[F2x] Probleme mit Dienste-Update nach Codierung

Diskutiere Probleme mit Dienste-Update nach Codierung im HiFi, Navi & Kommunikation Forum im Bereich Allgemeines zu den 1er BMW Modellen; Ich wünsche einen guten Morgen meine lieben, Ich hoffe ihr könnt mir helfen, da ich mittlerweile verzweifelt bin. Ich habe bei meinem F20 BJ...

  1. #1 tiebiex, 11.12.2020
    tiebiex

    tiebiex 1er-Interessent(in)

    Dabei seit:
    11.12.2020
    Beiträge:
    11
    Zustimmungen:
    1
    Ich wünsche einen guten Morgen meine lieben,
    Ich hoffe ihr könnt mir helfen, da ich mittlerweile verzweifelt bin.

    Ich habe bei meinem F20 BJ 2017 durch einen Codierer Apple Carplay freischalten lassen.
    Zuvor habe ich durch BMW die Firmware auf die Version von 04/ 2020 bringen lassen.
    Die Freischaltung von carplay und eine Verbindung mit einem Gerät mit IOS 13,5X hat auch funktioniert. Leider endete es dabei aber auch auch.
    Eine Verbindung mit Ios 14.2 Geräten scheitert.
    Wähle ich in der Übersicht Connected Drive -Options - Dienste Aktualisieren aus, folgen immer die gleichen Muster:
    Es wird ein Update in der Größe von 5,1 mb herunterladen. Mal läuft der Balken nach gefühlten Stunden bis zum Ende, mal aber endet er aber auch bei ca 70% stecken. Dann wechselt der Bildschirm auf „keine Datenverbindung“.
    Allerdings ist das Update nicht installiert und wenn ich die Dienste erneut aktualisiere, beginnt der Spaß von neuem.

    Hat jemand einen Ratschlag oder Lösungsansatz für mich?
    Ich würde im Zweifel auch zu BMW gehen, allerdings weiß ich nicht wie auf die Freischaltung reagieren würden.
    Die beigefügten Bilder beziehen sich auf die Infos im Text.

    Ich bin für jeden Ratschlag dankbar.
    Euer Tiebiex
     

    Anhänge:

  2. #2 DominikS66, 12.12.2020
    DominikS66

    DominikS66 1er-Liebhaber(in)

    Dabei seit:
    04.11.2011
    Beiträge:
    1.088
    Zustimmungen:
    179
    Ort:
    Landkreis Rastatt
    Fahrzeugtyp:
    125i
    Motorisierung:
    125i
    Modell:
    Hatch (F20)
    Baujahr:
    01/2019
    Spritmonitor:
  3. #3 tiebiex, 12.12.2020
    tiebiex

    tiebiex 1er-Interessent(in)

    Dabei seit:
    11.12.2020
    Beiträge:
    11
    Zustimmungen:
    1
    Danke für die Tipps. Leider führen sie nicht zum Erfolg. den Neustart Trick aus dem Video habe ich etwa 30x nun probiert. An unterschiedlichen Tagen.
    die Einstellung auf Reddit habe ich auch angeklickt. Er hat Carplay auch aktiviert.
    Mein Problem ist vielmehr, dass die bmw Dienste nicht aktualisiert werden bzw. exakt dieses eine Update nicht installiert wird. Alle anderen Updates macht er. nur dieses eine Update will er nicht machen. Dieses lädt er jedes mal aufs neue herunter. Denn mit dem alten IOS funktioniert es ja schließlich.

    Hat jemand eine Ahnung was folgt, wenn ich den BMW mit gecrackten CarPlay zu BMW fahre? Führt dies zu weitergehenden Stress?
     
  4. #4 LACNR, 14.12.2020
    Zuletzt bearbeitet: 14.12.2020
    LACNR

    LACNR 1er-Liebhaber(in)

    Dabei seit:
    25.02.2018
    Beiträge:
    1.146
    Zustimmungen:
    195
    Fahrzeugtyp:
    116i (FL)
    Modell:
    Hatch (F20)
    Ich verstehe nicht ganz, mit einem iPhone mit iOS 13.5 kannst du die Dienste aktualisieren im BMW und wenn du ein Handy mit iOS 14.2 nutzt nicht? Oder kannst grundsätzlich keine Dienste mehr aktualisieren? Oder meinst mit Dienste ein Update für Apple Car Play?

    Im ersten Fall hätte ich gesagt es liegt dann eben an iOS 14.2, ansonsten weil du Apple Car Play auf falschen Wege bekommen hast und es ja in deinem Connected Drive Konto nicht gebucht ist und deshalb vermutlich nicht möglich ist sich mit dem Server zu finden da es keine Authentifizierung der BMW Server erhält.

    Nun, wenn ein IT-Techniker reinschaut könnte er sicher sehen dass jemand fremdes etwas freigeschaltet hat wenn er an den Stellen schaut und wenn du sagst Apple Car Play Update geht nicht dann werden die ja schon sehen dass du eigentlich kein Apple Car Play haben dürftest. Dazu müssen die nichtmal an dein System dran, da Auto und Server kommunizieren kann auch der Kundendienst aus München sehen wann, welches Update du machst bzw. gemacht hast und welche Version du hast in Echtzeit. Könnte mir vorstellen das bei einem Fehler dort steht woran es liegt.
    .
     
    tiebiex gefällt das.
  5. #5 tiebiex, 15.12.2020
    tiebiex

    tiebiex 1er-Interessent(in)

    Dabei seit:
    11.12.2020
    Beiträge:
    11
    Zustimmungen:
    1
    Hey Lacner,
    danke dir für die ausführliche Antwort.
    An die Möglichkeit einer Abfrage habe ich noch gar nicht gedacht.
    Es war übrigens so gemeint:
    Mit dem IOS 13,5 Gerät funktioniert carplay und ich kann es nutzen.
    Mit dem Ios 14,2 scheitert jede Verbindung zwischen BMW uns dem Iphone.
    Wähle ich nun „Dienste aktualisieren“, führt dies nur dazu, dass das gleiche Update heruntergeladen aber nicht installiert wird.

    Es wäre natürlich sehr schade, wenn es nicht liefe. Schließlich erlaubt mit BMW nicht einmal den Originalkauf, da die Komforttelefonie bei dem Kauf nicht mitgebucht wurde.
     
  6. #6 DominikS66, 15.12.2020
    Zuletzt bearbeitet: 15.12.2020
    DominikS66

    DominikS66 1er-Liebhaber(in)

    Dabei seit:
    04.11.2011
    Beiträge:
    1.088
    Zustimmungen:
    179
    Ort:
    Landkreis Rastatt
    Fahrzeugtyp:
    125i
    Motorisierung:
    125i
    Modell:
    Hatch (F20)
    Baujahr:
    01/2019
    Spritmonitor:
    Ich würde hier mal Birnen und Äpfel trennen (oder besser gesagt, die beiden Vorgänge haben m.E. nicht miteinander zu tun).

    Das Update der Connected Drive Dienste hat m.M. eigentlich nichts mit der IOS-Version auf deinem Iphone zu tun. Das es nicht funktioniert, könnte durchaus mit dem "Hack" zu tun haben, wie LACNR schon schrieb. Aber die gennanten unterschiedlichen Ausführungszeiten deuten evt. auch auf ein Mobilfunk-Empfangsproblem deiner HU hin. Bist du mal testweise an eine Stelle gefahren, von welcher du weißt, das der Mobilfunkempfang gut ist, und zwar für alle Provider, und hast dort versucht, das Update auszuführen ?

    Und hast du schon einmal ein Softwareupdate über USB-Stick probiert ? Siehe auch hier: https://www.bmw.de/de/topics/service-zubehoer/bmw-connecteddrive/bmw-software-update.html

    Und zu deinem Verbindungsproblem: Ich gehe jetzt mal selbstredend davon aus, dass du dein Iphone über Bluetooth verbinden willst. Du hast ja den Hardreset schon probiert, hast du auch VOR dem Hardreset Bluetooth auf deinem Iphone explizit ausgeschaltet ? Reset der Netzwerkeinstellungen schon probiert ?
    (Kleiner Hinweis am Rande: Mit IOS14 wurden ja auch solche nette Funktionen wie MAC-Adressen-Verschwurbselung für Wlan-Verbindungen eingeführt, das sollte zwar nichts mit BT-Verbindungen zu tun haben, aber wer weiß...)
    Tja das sind so kleine Details, die man vielleicht gleich am Anfang erwähnen sollte...
     
    tiebiex gefällt das.
  7. #7 tiebiex, 15.12.2020
    tiebiex

    tiebiex 1er-Interessent(in)

    Dabei seit:
    11.12.2020
    Beiträge:
    11
    Zustimmungen:
    1
    Hey DominikS66,
    auch dir danke ich für eine Antwort.

    Der BMW war zuvor in der Werkstatt, um das Fahrzeug auf die aktuellste Firmware zuflashen. Daher ist kein USB Update verfügbar.

    Ich probiere dieses Update nun mittlerweile seit ca 2 Wochen in der kompletten Leipziger Stadt und Umland. Andere Update hatte er ja problemlos installiert.

    Mit der IOS Version wollte ich nur meinen Verdacht äußern: Nämlich, dass die Grundversion ordnungsgemäß installiert ist und diese nur die alte IOS Version unterstützt. Lediglich die APP Aktualisierung, die ich für ein Update für CarPlay vermute, lässt sich nicht installieren.

    Ja mir ist bekannt, dass BMW lediglich die drahtlose Verbindung unterstützt. Ich wähle auch die Verbindung über Allgemein --> CarPlay (Die Alternative über die Bluetooth Einstellungen habe ich allerdings auch schon probiert. So hatte ich auf besagten IOS 13,5 Gerät die Verbindung auch hergestellt.
    Nein vor dem Hardreset hatte ich Bluetooth nicht explizit ausprobiert.Dies kann ich heute gerne noch einmal probieren.
    Den Reset der Netzwerkeinstellungen probiere ich heute.

    Sorry, mir war leider nicht bewusst, dass dies relevant ist. Der Codierer sagte mir, dass die Komforttelefonie nichts mit CarPlay zu tun hat und BMW dies nur für die Gewinnmaximierung fordert.
     
  8. #8 tiebiex, 15.12.2020
    tiebiex

    tiebiex 1er-Interessent(in)

    Dabei seit:
    11.12.2020
    Beiträge:
    11
    Zustimmungen:
    1
    Sollte ich zu blind für die Bearbeitungsfunktion sein, bitte ich es zu entschuldigen.

    Es gibt jedenfalls ein kleines Update: Trotz Zurücksetzen der Netzwerkeinstellungen und mittlerweile IOS 14.3 ist keine Besserung eingetreten

    Liebe Grüße

    Euer Tiebiex
     
  9. LACNR

    LACNR 1er-Liebhaber(in)

    Dabei seit:
    25.02.2018
    Beiträge:
    1.146
    Zustimmungen:
    195
    Fahrzeugtyp:
    116i (FL)
    Modell:
    Hatch (F20)
    Du sagtest mehrmals das andere Update konnte es installieren, welches Update vor dem Hack des CarPlay oder als du es bereits hattest?

    Meine Vermutung du kannst die Connected Drive Dienste nicht aktualisieren weil du nicht rechtmäßig CarPlay hast und im iDrive daher sich irgendwas querstellt und es nicht erlaubt oder das Update abbricht, da du einen Dienst hast der laut dem BMW Server nicht vorhanden sein sollte und die Connected Drive Dienste nicht korrekt überprüft und installiert werden können.

    Eine andere Vermutung wäre dass das Problem auch durch die neue Firmware die bei BMW installiert wurde hervorgerufen wurde. Hast du das Software Update vor oder nach dem du bereits CarPlay codieren lassen hast machen lassen?

    Vielleicht gibt es mometan auch Probleme die Dienste zu aktualisieren, ich schaue gleich bei mir habe zwar eine andere iDrive Stufe aber sollte ja über die selben Server laufen.

    Kann auch sein dass die Komfortelefonie und CarPlay doch zusammenhängen, nicht für den Betrieb aber für das iDrive Funktionstechnisch eine Vorausetzung sind das CarPlay gebucht werden kann.

    Vielleicht hat der Codierer auch irgendwas falsch gemacht, kann mometan einfach vieles sein.
     
  10. #10 tiebiex, 22.12.2020
    tiebiex

    tiebiex 1er-Interessent(in)

    Dabei seit:
    11.12.2020
    Beiträge:
    11
    Zustimmungen:
    1
    Hey,

    Danke euch für eure Hilfe.

    Ich konnte mich die letzten Tage nicht melden. Allerdings habe ich die Lösung mithilfe eines anderen Codierers gefunden. Ich wollte euch und alle anderen dran teilhaben.

    Mein Problem war die fehlende WiFi Antenne. Nachdem ich das Navi ausgebaut hatte, zeigte sich, dass keine Antenne hatte. Nachdem ich mein IPhone an die Einheit ranhielt, baute sogar mein IOS 14.3 Gerät die Verbindung sofort auf.
    Da die Verbindung nur sehr schwach war brach die Verbindung regelmäßig ab.

    Habe nun eine Antenne für drei Euro bestellt. Damit sollte es funktionieren.

    Euch noch einen schönen Abend.

    Liebe Grüße

    Tiebiex
     
  11. LACNR

    LACNR 1er-Liebhaber(in)

    Dabei seit:
    25.02.2018
    Beiträge:
    1.146
    Zustimmungen:
    195
    Fahrzeugtyp:
    116i (FL)
    Modell:
    Hatch (F20)
    Inwiefern den eine WiFi Antenne? BMW Dienste werden ja über die verbaute SIM Karte (evntl muss BMW Online/Connected Drive gebucht sein) aktualisiert, eine Werksantenne sollte vermutlich in der Flosse drin sein, korrigiert mich bitte.
     
  12. #12 DominikS66, 22.12.2020
    DominikS66

    DominikS66 1er-Liebhaber(in)

    Dabei seit:
    04.11.2011
    Beiträge:
    1.088
    Zustimmungen:
    179
    Ort:
    Landkreis Rastatt
    Fahrzeugtyp:
    125i
    Motorisierung:
    125i
    Modell:
    Hatch (F20)
    Baujahr:
    01/2019
    Spritmonitor:
    Wifi-Antenne (also Wlan im Auto) ? hast du die Option Wlan-Hotspot in deinem 1er verbaut ? Oder meinst du eine Bluetooth-Antenne ?
    @LACNR Wifi-Antennen sind nur im Auto, nicht außen verbaut (würde auch keinen Sinn machen...)
     
  13. #13 tiebiex, 22.12.2020
    tiebiex

    tiebiex 1er-Interessent(in)

    Dabei seit:
    11.12.2020
    Beiträge:
    11
    Zustimmungen:
    1
    Hey. also es war kein Problem mit dem Update.
    ich hatte eine Verbindung mit Ios 14.3. dass es kurzzeitig mit einem ios 13 gerät ging war wohl Zufall.
    Das besagte connected Drive Update, welches er immer wieder runterlädt, macht er auch heute noch.

    Die Antenne müsste tatsächlich die wifi antenne sein. Habe ein Bild angefügt von der Hauptunit ohne Antennenanschluss. Siehe vierten Anschluss von rechts.
    Dadurch, dass ich nicht den Hotspot hatte, hatte ich wohl auch die entsprechende Antenne nicht.
    Nachdem ich nämlich mein Handy ganz nah gehalten hatte, hatte ich eine Verbindung.
     

    Anhänge:

  14. #14 LACNR, 22.12.2020
    Zuletzt bearbeitet: 22.12.2020
    LACNR

    LACNR 1er-Liebhaber(in)

    Dabei seit:
    25.02.2018
    Beiträge:
    1.146
    Zustimmungen:
    195
    Fahrzeugtyp:
    116i (FL)
    Modell:
    Hatch (F20)

    Ich muss die WiFi Antenne mit der Telefonieanbindung verwechselt haben wenn man Wireless Charging/Snap In Adapter hat und die Außenantenne zur Signalverstärkung genutzt wird.

    Ich bin gerade verwirrt, anfangs sagtest du, du hast ein Problem mit den BMW Diensten, dass du kein Update machen kannst wenn du iOS 14.2 benutzt willst... aber dafür brauchst du keine WiFi Antenne um BMW Dienste zu aktualisieren.

    Die WiFi Antenne brauchst du vermutlich ja nur für den T-Mobile HotSpot den BMW als Connected Drive Dienst anbietet, das sollte aber nichts mit Apple CarPlay zutun haben.

    Ich musste mich nochmal reinlesen, also mit iOS 13.5 kannst du CarPlay nutzten und mit 14.2 nicht? Dann liegt es einfach an iOS 14.2, man müsste sich umhören ob andere ebenfalls Probleme mit der Version haben.


    Wenn du kein Handy verbunden hast, lass man iPhone komplett außen vor.. kannst du dann das bestehende BMW Dienst Update vollständig machen?


     
  15. #15 DominikS66, 22.12.2020
    DominikS66

    DominikS66 1er-Liebhaber(in)

    Dabei seit:
    04.11.2011
    Beiträge:
    1.088
    Zustimmungen:
    179
    Ort:
    Landkreis Rastatt
    Fahrzeugtyp:
    125i
    Motorisierung:
    125i
    Modell:
    Hatch (F20)
    Baujahr:
    01/2019
    Spritmonitor:
    ist dein IPhone dabei über Bluetooth oder über WLAN verbunden ?
     
  16. #16 tiebiex, 22.12.2020
    tiebiex

    tiebiex 1er-Interessent(in)

    Dabei seit:
    11.12.2020
    Beiträge:
    11
    Zustimmungen:
    1
    Bei carplay nutzt er doch beides. Ich denke vor allem aber WLAN. Zumindest vermute ich dies, da ich mit der BT Verbindung keinerlei Probleme hat.


    Es war meine Vermutung, dass es ein CarPlay Update sei, da ich einmal mit ios 13.5 eine Verbindung hatte und anschließend nach dem Update keine mehr. Dies lag aber wohl nicht am Update.


    Laut Bimmerpost und besagten Codierer benötige ich sie auch für Carplay, da das auto ein eigenes carplay wifi erzeugt.


    Jein. Ich hatte nur einmal eine Verbindung mit Ios 13.5. genauso wie heute mit ios 14. doch nach dem einen Erfolg hatte ich besagtes Gerät geupdatet, sodass ich keinen zweiten Test machen konnte. Da reichte wohl die Verbindung kurz. Warum weiß ich nicht.
    Er lädt das Update vollständig. Sowohl mit als auch ohne irgend ein anderes Gerät installiert. aber nach wie vor installiert er es nicht. Ich kann es jedes mal aufs neues starten.

    CarPlay funktioniert nun aber, sofern das Handy anliegt.

    Hoffe ich konnte Klarheit reinbringen
     
  17. #17 DominikS66, 22.12.2020
    DominikS66

    DominikS66 1er-Liebhaber(in)

    Dabei seit:
    04.11.2011
    Beiträge:
    1.088
    Zustimmungen:
    179
    Ort:
    Landkreis Rastatt
    Fahrzeugtyp:
    125i
    Motorisierung:
    125i
    Modell:
    Hatch (F20)
    Baujahr:
    01/2019
    Spritmonitor:
  18. #18 LACNR, 22.12.2020
    Zuletzt bearbeitet: 22.12.2020
    LACNR

    LACNR 1er-Liebhaber(in)

    Dabei seit:
    25.02.2018
    Beiträge:
    1.146
    Zustimmungen:
    195
    Fahrzeugtyp:
    116i (FL)
    Modell:
    Hatch (F20)
    Ich glaube du verwechselst etwas beim Update wenn BMW Dienste aktualisieren drückst. In der Regel sind die Updates so klein, dass die in Sekunden installiert sind. Wenn es immer wieder das gleiche ist, gibt es kein neues nur die Verbindungsdaten für die Dienste müssen halt immer abrufbar sein daher jedesmal das Update.

    Nachdem du BMW Dienste Aktualisieren gedrückt hast, musst du schnell und sofort zu Datenübertragung um zu sehen was der herunterlädt, das Update wird gleichzeitig installiert für mein Verständnis, in der Regel sind vermutlich sowieso nur die Verbindungsdaten die überprüft werden es wird nicht angezeigt dass es installiert wird. Wenn der es vollständig runtergeladen hat ist die Datenübertragung vollständig und das Update beendet, so ist bei mir zumindest.

    Zu CarPlay

    CarPlay funktioniert ja über entweder Wireless Charging Ablage oder eben Komforttelefonie (Bluetooth). Da du wahrscheinlich kein Wirless Charging hast, muss du es über Bluetooth machen. Ich kann mir nicht vorstellen, dass du ohne WLAN Hot Spot Option und ohne entsprechende Antenne eine Verbindung haben kannst über WiFi zum Radio wenn du ein Handy dran hast, ja gut es sei denn der Codierer hat WLAN Option aktiviert und der Input Empfangsbereit ist.

    Edit: Okay scheinbar nutzt CarPlay dann doch beides. :lol:
     
  19. #19 tiebiex, 22.12.2020
    tiebiex

    tiebiex 1er-Interessent(in)

    Dabei seit:
    11.12.2020
    Beiträge:
    11
    Zustimmungen:
    1
    Wäre es nur BT benutzen, müsste ich doch gar keine Probleme aufwerfen? Die normale BT Verbindung funktioniert doch.

    Ich glaube, dass er sehr wohl ein update macht. Es hat 5 Mb und meldet Apps werden aktualisiert (siehe Bilder oben). Es handelt sich nicht um besagte Verbindungsdaten. Die macht er auch. Was da schief läuft weiß ich nicht. Es hatte jedenfalls nichts mit carplay zutun. Obwohl ich es ursprünglich dachte
     
  20. LACNR

    LACNR 1er-Liebhaber(in)

    Dabei seit:
    25.02.2018
    Beiträge:
    1.146
    Zustimmungen:
    195
    Fahrzeugtyp:
    116i (FL)
    Modell:
    Hatch (F20)

    Ja scheinbar wird aktives WLAN weshalb auch immer ebenfalls benötigt.


    Ein Update macht er schon auch wenn es immer wieder die selben Daten sind, er überschreibt die vorhandenen selbst wenn es die selben sind bzw. schon installiert wurde so meine Vermutung.

    Wenn die Anzeige bis zum Ende läuft und Erfolgreich meldet oder etwas in der Art sollte das Update beendet sein bei den Apps. Vielleicht wenndm du ein kurzes Video machen würdest, könnte man es besser verstehen was der die wann anzeigt bezüglich des Updates.

    Du sagtest du hast ja ein Software Update bekommen, vielleicht ist dies der Auslöser für das Problem bzw. hast du BMW Online usw. gebucht? 98% der Apps sind ja Bestandteil davon. Die anderen 2% sind vermutlich Pannenhilfe und diese andere da weiß den Namen jetzt nicht auf jeden Fall steht da Dienst bereit und Dienst starten wenn man in die beiden reingeht.
     
Thema:

Probleme mit Dienste-Update nach Codierung

Die Seite wird geladen...

Probleme mit Dienste-Update nach Codierung - Ähnliche Themen

  1. [F20] B38 gibt es Probleme mit Steuerkette?

    B38 gibt es Probleme mit Steuerkette?: Hallo Forumskollegen Mein 118i Bj 2016 mit B38 + 8-Gang Automatik) hat jetzt 48TKM drauf. Ich habe jetzt leichte Geräusche kann es aber nicht...
  2. Probleme mit der Vanos (Steuerkette?) N43

    Probleme mit der Vanos (Steuerkette?) N43: Moin! Ich weiß, dass Internet ist voll mit dem Problem... Wir haben vor einem Jahr einen 2008er 116I gekauft, leider war ich mir da noch nicht...
  3. [E81] BMW 1er extreme Probleme beim Starten

    BMW 1er extreme Probleme beim Starten: Hallo miteinander, ich habe schon seit längerem ein Problem mit meinem BMW. Er hat starke Probleme beim Starten. Zu meinem Auto: Es ist ein 1er...
  4. Schlüssel probleme. Verdeck wird geöffnet, will nicht abschließen usw.

    Schlüssel probleme. Verdeck wird geöffnet, will nicht abschließen usw.: Moooooin, ich habe seit heute ein Problem mit meinem Schlüssel. Habe vorhin geparkt, Dach hochgemacht und bin ausgestiegen. Dann nach 20 Minuten...
  5. [F2x] Probleme mit dem Sound

    Probleme mit dem Sound: Hallo zusammen! Ich habe aktuell ein echtes Problem. Vor einer ganzen Weile ist mein Sound in meinem F21 komplett ausgefallen. Keine Musik, kein...