[E87] Fehlercode 2C31, gelbe MKL, Fehlersuche

Diskutiere Fehlercode 2C31, gelbe MKL, Fehlersuche im BMW 118i Forum im Bereich Informationen zum 1er E-Modell 2004-2013; Hallo allerseits, Mein Ex-E87 (N43B20 EZ09/2007, mitlerweile 175 tkm)hat sich mit einem Problemchen zurückgemeldet. Die gelbe MKL war an, es war 1...

  1. #1 DominikS66, 05.12.2021
    DominikS66

    DominikS66 1er-Liebhaber(in)

    Dabei seit:
    04.11.2011
    Beiträge:
    1.269
    Zustimmungen:
    237
    Ort:
    Landkreis Rastatt
    Fahrzeugtyp:
    125i
    Motorisierung:
    125i
    Modell:
    Hatch (F20)
    Baujahr:
    01/2019
    Spritmonitor:
    Hallo allerseits,
    Mein Ex-E87 (N43B20 EZ09/2007, mitlerweile 175 tkm)hat sich mit einem Problemchen zurückgemeldet. Die gelbe MKL war an, es war 1 Fehler eingetragen, 2C31 Lambdaregelung, Abgas nach Kat zu mager. Na toll, das kann ja tausend Ursachen haben. Also hab ich mein Torque-Dashboard drangehängt und eine Testfahrt gemacht. Folgendes habe ich beobachtet:
    - Motorleistung in Ordnung, keine Probleme, läuft absolut rund
    - Schichtladebetrieb wird nicht mehr aktiviert
    - etwas höherer Verbrauch
    - kein nennenswerter Ölverbrauch
    - LTFB-Wert bei geringer Last weit im Plus (Gemisch wird also durch die Regelung ordentlich angereichert)
    - NoX misst bei geringer Last Stickoxid-Belastung trotz Homogen-Betrieb
    - Bei höherer Last gehen LTFB+STFB in Summe gegen Null, NoX geht zurück
    - Messwerte der Lambdaregelsonde unauffällig.
    - Test im Leerlauf: Beim Abnehmen des Motoröldeckels sackt die Drehzahl deutlich ab, Motor ruckelt eine Weile und Gemisch wird spürbar nachgeregelt.

    Da bei höherer Last die Regelung wohl richtig funktioniert (weniger Unterdruck im Ansaugsystem) und das magere Gemisch nur bei wenig Belastung aufttritt, tippe ich im Moment auf ein defektes KGE-Ventil, gefolgt von einer defekten Lambdasonde. Ich wollte hier mal euere Meinung dazu hören.
     
  2. #2 DominikS66, 18.12.2021
    DominikS66

    DominikS66 1er-Liebhaber(in)

    Dabei seit:
    04.11.2011
    Beiträge:
    1.269
    Zustimmungen:
    237
    Ort:
    Landkreis Rastatt
    Fahrzeugtyp:
    125i
    Motorisierung:
    125i
    Modell:
    Hatch (F20)
    Baujahr:
    01/2019
    Spritmonitor:
    Ich hab da mal was in Anlehnung an den BMW Testplan gebastelt...
    20211218_101154.jpg
     
  3. #3 DominikS66, 19.12.2021
    DominikS66

    DominikS66 1er-Liebhaber(in)

    Dabei seit:
    04.11.2011
    Beiträge:
    1.269
    Zustimmungen:
    237
    Ort:
    Landkreis Rastatt
    Fahrzeugtyp:
    125i
    Motorisierung:
    125i
    Modell:
    Hatch (F20)
    Baujahr:
    01/2019
    Spritmonitor:
    Neuigkeiten: Prüfung mit dem Unterdruckadapter ergab einen leichten Unterdruck bei Leerlauf, lt. BMW sind ja -0.04 bar Differenzdruck zur Umgebung in Ordnung. Nun ist das Manometer ja nicht so genau bzw. 0.04 lässt sich daran nicht ablesen. Daher haben wir die Drehzahl etwas angehoben, bei 1500-2000 U/min waren es dann -0.2 bar Differenzdruck, in diesem Bereich hat die DME-Regelung dann auch das Gemisch stark angefettet (beobachtet mit Torque pro, LTFB/STFB Werte).
    Zum Abschluss haben wir dann noch den Kurbelgehäuseentlüftungsschlauch abgezogen und mit Gaffertape verschlossen. Die Kurbelgehäuseentlüftung haben wir testweise "ganz klassisch" an eine kleine Flasche mit Entlüftungsloch angeschlossen und eine Testfahrt gemacht.
    IMG-20211218-WA0015.jpg
    Und siehe da, die Regelwerte (Summenwerte LTFB+STFB) pendeleten sich wieder um den Nullpunkt herum ein und als Sahnehäubchen waren nach ca. 10 km alle OBDReadiness-Tests wieder erfolgreich abgeschlossen (zuvor wurde wochenlang immer die Lamdasonde und der Katalysator als nicht abgeschlossen angezeigt, was wohl letztendlich zur gelben MKL geführt hat).
    Nächster Step wäre dann wohl die Erneuerung der Zylinderkopfhaube...oder hat jemand eine andere Idee, wie man die Membran an der vorhandenen Zylinderkopfhaube instandsetzen könnte ?

    PS, der N43 klingt ohne Motordämmung bei Fahrt echt schlimm...
     
  4. #4 DominikS66, 03.02.2022
    DominikS66

    DominikS66 1er-Liebhaber(in)

    Dabei seit:
    04.11.2011
    Beiträge:
    1.269
    Zustimmungen:
    237
    Ort:
    Landkreis Rastatt
    Fahrzeugtyp:
    125i
    Motorisierung:
    125i
    Modell:
    Hatch (F20)
    Baujahr:
    01/2019
    Spritmonitor:
    Kurzes Update meiner MSD80-Odysee:
    - History- und Info-Speicher der MSD80 ausgelesen - ungewöhnlich, letzte Desulfatierung ist mehr als 17tkm her ? Km Stand der letzten Desulfatierung liegt im Bereich eines Werkstattaufenthalts, bei dem auch Fahrzeugdiagnosen durchgeführt wurden...(wird später noch interessant). Scheinbar wurde der Schichtladebetrieb schon länger nicht mehr aktiviert.
    - Zylinderkopfhaube neu - brachte kaum Besserung
    - beide Lamdasonden neu, Adaptionen Lambdasonden und Gemischaufbereitung gelöscht und neu angelernt - Fehler 2C31 "Gemisch zu mager" ist seither nicht mehr aufgetaucht und auch keine anderen Fehlereinträge. Aber: OBD Readyness wird nicht mehr gesetzt :cry: obwohl nach mehreren 100 km keinerlei Fehlereinträge vorhanden sind). OBD Fehlerflags Lambdasonde und Katalysator-Wirkung gesetzt. Lambdawerte sind plausibel und stabil. Schichtladebetrieb wird ohne ersichtlichen Grund nicht automatisch aktiviert (nur manuell möglich). Motorlauf ist aber ruckelfrei und Leistung normal vorhanden.
    - Lambda-Adaptionen für Injektoren zurückgesetzt und neu angelernt - keine Besserung, aber auch keine Fehlereinträge
    -Lektüre bei den Bimmerprofs zum Thema Schichtladebetrieb (stratified charge) bringt zusätzlich einen kleinen Hinweis: Beim Rücksetzen der Adaptionen mit Ista D+ scheint es wohl vorzukommen, dass anschließend der Schichtladebetrieb nicht mehr aktiviert wird...Abhilfe laut Bimmerprofs: benutze Inpa statt Ista D+ (ich benutze aber Ista D+ gar nicht...Werkstatt ? Der letzte Eintrag zur Desulfatierung im History-Speicher würde passen)
    - testweise NOx Sensor getauscht, Alle Adaptionswerte (nicht nur Lambdasonden und Gemischaufbereitung) gelöscht, anschließend 2-Stündige Adaptionsfahrt durchgeführt und manuelle Desulfatierung - keine Besserung. - der NOx Ersatz-Sensor hat wohl eine Macke in der Elektronik und schmeist ständig verschiedene Kurzschlussfehler und dadurch resultierend am Ende Fehlercode 30DA (NOx Messung nicht verfügbar). Jetzt gibts wenigestens einen plausiblen Grund dafür, das der Schichtladebetrieb nicht funktioniert.
    - ursprünglichen NOX Sensor wieder verbaut, Kabel der Lambdasonden kontrolliert und gereinigt, Verbindungsstecker prophylatisch gereinigt und zum Schutz mit Elektronik-Kontaktreinigungsspray behandelt. Fehlerspeicher in der MSD80 gelöscht - und nach der Warmlaufphase wurde der Schichtladebetrieb endlich wieder automatisch aktiviert. \:D/ Nach nur 20 km fahrt sind jetzt auch alle OBD Readyness Flags wieder korrekt gesetzt. Auch die NOx Werte sehen jetzt wieder plausibel aus.
    Was jetzt genau die Ursache war ... Softwarefehler ? Absicht ? :-k
     
    RS187i gefällt das.
Thema:

Fehlercode 2C31, gelbe MKL, Fehlersuche

Die Seite wird geladen...

Fehlercode 2C31, gelbe MKL, Fehlersuche - Ähnliche Themen

  1. [E82] Fehlercode 2A31 - Exzenterwellensensor defekt?

    Fehlercode 2A31 - Exzenterwellensensor defekt?: Hallo zusammen, ich habe folgendes Problem: Beim starten ruckelt der Motor für ein paar Sekunden und nach meiner Wahrnehmung ist die Drehzahl...
  2. Klimaanlage kühlt nicht, Fehlercode 9C4D, E87 118d

    Klimaanlage kühlt nicht, Fehlercode 9C4D, E87 118d: Hallo, meine Klimaanlage kühlt nicht mehr, die Lüftung und Heizung funktioniert aber noch. Mit Carly hab ich den Fehlercode 9C4D auslesen können,...
  3. Fehlercode 3F31 Raildrucksensor

    Fehlercode 3F31 Raildrucksensor: Servus zusammen, Ich fahre einen Bmw 123d Coupe (E82) aus dem Jahr 2010. Mir ist letztens für einen Bruchteil einer Sekunde die...
  4. Fehlercodes

    Fehlercodes: Servus in die Runde, habe nach längerer Zeit Mal wieder in der Fehlerspeicher gesehen und folgendes würde mir angezeigt, scheint aber alte Codes...
  5. Fehlercode BMW 118i E87 Motorcode N43 B20 A Bj. 06-09

    Fehlercode BMW 118i E87 Motorcode N43 B20 A Bj. 06-09: Hallo, habe folgendes Problem seit einiger Zeit leuchtet die Motoranzeige immer wieder auf. Beim Auslesen kommt die Antwort Fehlercode DTC 2C2D (...